Billing DNS Caching
Incident Report for Soularc
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 17:08 ACDT
Identified
We have identified an issue with local browsers/network caching our billing system incorrectly.
If you experience an issue whilst logging into our billing system, try the following:
1) Clearing your browser cache
2) Using a different browser
3) Using a different network
Posted Apr 01, 2021 - 11:21 ACDT
This incident affected: Billing System.